The NIS+ support for glibc 2.x was written from scratch from me. The complete NIS+ API and all necessary functions for the glibc NSS interface are implemented. DES authentication for NIS+ (secure level 2) works. If your distribution comes with glibc 2.1.3 or later (like SuSE Linux 6.4 or Red Hat Linux 7), you don't need to install a new version.

The first official glibc version with working NIS+ was the 2.1.3 release.

For more information about the GNU C Library, look at http://www.gnu.org/software/libc/libc.html

Back
 

Thorsten Kukuk - kukuk@linux-nis.org
Last modified: Tue Nov 28 22:38:05 CET 2006